The EmaiI Signature Web Portal - Help Center

What is the latest version of Exchange Connector?

It is always best practice to ensure that you have the latest version of the Exchange connector on your Exchange Server. 

Exchange Connector - Exchange Connector (Current version is 2.2.1)                                               Transport Agent - Exchange 2013 or above (Xink_Agent.msi),  for Exchange  2010 (emailsignature_exchange (v2.0.1).msi)

Note: Exchange connector version 2.1.0 requires .NET 4.7.2 runtime or higher (Download .Net Framework)

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.