The EmaiI Signature Web Portal - Help Center

Windows Installer Error Prompt - Xink client version 3.2.16

Xink client version 3.2.16 is no longer capable of auto-updating itself and results in this pop-up message: 


Solution

Open an internet browser, paste this link https://downloads.xink.io/win/client and press enter. 

It should download a new installer. 

Double-click on the xinkClient. msi and it will run by itself. 

It will prompt you to close the current application. 

Click ok and the update will run.

Once the prompt is gone, go to your system tray and click on the Xink icon 

The Xink client version should be 3.2.20.1


Note: This only applies to users who have downloaded the Xink client via email invitation. For those who have similar error messages but have the MSI applied to their gpo's kindly send an email at support@xink.io


Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.